CenturyLink / Level3 Outages in US

Major incident Cloud - Hosted Microsoft Dynamics CRM Services Cloud - Hosted Microsoft Dynamics GP Services Cloud - Hosted Desktop Service Cloud - FICS Hosting Platform MySecureDesktop Cloud Services
4 hours, 5 minutes, 51 seconds

Updates

Resolved

ACS Solutions Engineers report that CenturyLink has resolved an issue with Internet Bandwidth at all of our locations that began at approximately 6:15 AM ET. CenturyLink implemented a fix to their BGP configuration which should resolve the issue. BGP peering has been reestablished throughout the CenturyLink network. ACS Solutions has confirmed that environments appear stable at this time. ACS Solutions will continue to monitor the situation but at time time believe the issue to be resolved.

If you are still experiencing issues please reach out to the ACS Solutions Service Desk via phone, or open a ticket by sending an e-mail to support@mysyapps.com.

August 30, 2020 · 17:34 UTC
Update

CenturyLink is continuing to investigate the root cause of their backbone issues and has yet to provide us with a substantive update other than to advise that they have started routing traffic around their failed centers. This has caused most of the connectivity issues on the Internet to resolve but we are still seeing periodic slowdowns and disconnects. As soon as we received further updates from CenturyLink, we will pass them along.

August 30, 2020 · 15:55 UTC
Update

We are continuing to monitor the situation with CenturyLink / Level3 and as of yet, they still do not have an ETA as to when their backbone services will return to normal. This is currently impacting most of the Internet services throughout the US. More updates as they become available.

August 30, 2020 · 14:23 UTC
Issue

CenturyLink / Level3 is currently experiencing networking issues throughout the US. This is impacting our customers ability to get to some of our services that are hosted in our data center environment.

The ACS Solutions Operations Team have removed CenturyLink from our routing to attempt to mitigate the issue. This may improve connectivity, though if traffic traverses the CenturyLink network external to ACS Solutions you may continue to see issues.

ACS Solutions continues to push CenturyLink for a speedy resolution and will communicate progress as more information becomes available. Thank you for your patience and understanding.

August 30, 2020 · 13:33 UTC

← Back